Contents of this Guide

About Results ................................. 1
Results Menu Command Reference .......... 2
About Tables .................................. 3
Table Menu Command Reference ............. 3
Insert Menu Command Reference – Tables ... 4

Results & Tables

The Parts ..................................... 5
Selecting Columns, Rows & Titles .......... 6
Move a Column ................................ 6
Sorting the Results & Table Data .......... 6
Remove Columns ............................. 7
Applying Totals ............................. 7
Grand Totals ................................. 7
Inserting Break Totals ....................... 8
Remove a Break Total ....................... 10
Hide/Unhide Column ......................... 10

Formatting Results and Tables ............ 11
Column Titles ................................ 11
Row Numbers ................................ 11
Text Wrap .................................... 11
Suppress Duplicates ......................... 12
Alignment/Justify ............................ 12
Gridlines ..................................... 13
Border & Background ....................... 13
Spotlighter ................................... 14
Export Properties ......................... 16
Adding a Header & Footer .................. 16
In a BDM Hyperion document the Filter dialog box is used in three sections.

1. Query
2. Results
3. Table

1. In the **Query section** you are filtering the data from the warehouse.

**Warehouse**  **Results**

2. In the **Results section** you are filtering the data you have retrieved from the warehouse.

**Warehouse**  **Results**  **Reports, Pivots, Charts**

3. In the **Table section** you are filtering data from the Results section.

---

**Important**

Unless otherwise noted, this guide, images and information will apply to both the Results and Table sections.

---

**About Results** -

When you process a query, Hyperion retrieves data to your desktop and displays it in the Results section as columns. The Results section displays your dataset as it might appear in the database. Although the query may have accessed several different database tables, the Results section is consolidated into a single table. Each requested item is found in a column field, and there is a row for each record returned from the database.

All reports, including tables, pivots, charts, and those created using the Report Designer, are based on the data that is retrieved to the Results section.
The Results section is helpful in:

- verifying the accuracy of your query
- verify the data retrieved meets your exact specifications
- you can make changes and refine the data directly in the Results section
  - setting filters
  - creating computed elements and grouped items
- it can be formatted for a quick report
- add grand totals or subtotals
- compute data functions
- export to other applications
- print the section

### Results Menu Command Reference (modified list)

The following table provides a quick reference to the commands available on the Results menu and lists any related shortcuts.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
<th>Keyboard Shortcut</th>
<th>Shortcut Menu</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filter</td>
<td>Opens the Filter dialog box.</td>
<td>Ctrl+L</td>
<td></td>
</tr>
<tr>
<td>Sort Ascending</td>
<td>Sorts the selected column values in ascending order (alphabetical or numeric).</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Sort Descending</td>
<td>Sorts the selected column values in descending order (alphabetical or numeric).</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Remove</td>
<td>Removes the selected column (or data layout item).</td>
<td>Del</td>
<td></td>
</tr>
<tr>
<td>Break Total</td>
<td>Opens the Insert Break Total dialog box.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Grand Total</td>
<td>Opens the Insert Grand Total dialog box.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Hide Column</td>
<td>Hides the selected column from view.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Unhide Column</td>
<td>Opens the Unhide Column dialog box.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
A table is data arranged in columns. A Table section functions is used in much the same way as the Results section. All of the commands that are available on the Results menu are also available on the Table menu. However, you cannot apply complex filters or aggregate data in the Table section.

The data in a Table section is derived from the Results section that is active when you insert a new table. When you insert a Table section from the Results section, the new Table section is attached to the Results section. This means any changes to the results section are immediately transmitted to the Table section. (The Results section is the parent to the Table section.)

In a variety of ways, the Table section shares the same functionality as the Results section. Pivots, Charts, and other reports can be created based on a table's dataset in the same way reports are created from a Results section.

### Table Menu Command Reference (modified list)

The table below provides a quick reference to the commands available on the Table menu and lists any related shortcuts.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
<th>Keyboard Shortcut</th>
<th>Shortcut Menu</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filter</td>
<td>Opens the Filter dialog box.</td>
<td>Ctrl+L</td>
<td>*</td>
</tr>
<tr>
<td>Sort Ascending</td>
<td>Sorts the selected column values in ascending order (alphabetical or numeric).</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>Sort Descending</td>
<td>Sorts the selected column values in descending order (alphabetical or numeric).</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>Remove</td>
<td>Removes the selected column (or data layout item).</td>
<td>Del</td>
<td>*</td>
</tr>
<tr>
<td>Break Total</td>
<td>Opens the Insert Break Total dialog box.</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>Grand Total</td>
<td>Opens the Insert Grand Total dialog box.</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>Hide Column</td>
<td>Hides the selected column from view.</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
<td>Keyboard Shortcut</td>
<td>Shortcut Menu</td>
</tr>
<tr>
<td>---------------</td>
<td>------------------------------------</td>
<td>-------------------</td>
<td>---------------</td>
</tr>
<tr>
<td>Unhide Column</td>
<td>Opens the Unhide Column dialog box.</td>
<td></td>
<td>*</td>
</tr>
</tbody>
</table>

**Insert Menu Command Reference – Tables (modified list)**

The following table provides a quick reference to the commands available on the Insert menu and list any related shortcut menus. The command listed is available in the Query and Results sections.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>New Table</td>
<td>Inserts a new Table section.</td>
</tr>
</tbody>
</table>
There are many ways to enhance your Results and Table sections. Keep in mind that Results and Table sections' priority is data representation from the warehouse or computed items. Pivots, Reports (designed) and Charts may be more appropriate sections to use for reporting.

BDM Hyperion documents are created to automatically populate the Results sections with the data retrieved from the warehouse. When you create a Table, you will be populating it with the data you select from Results.

**The Parts**

1. Columns
2. Rows
3. Filters
4. Sorts
5. Section Pane
6. Catalog Pane
7. Data Layout
8. Row Status Bar
Selecting Columns, Rows & Titles

- **Select a Column** - Click anywhere inside the column.
- **Select a Row** – Click to the left of the row. If you have row numbers turned on, click on the number.
- **Select a Title** – Click anywhere inside the Title cell.

Move a Column – There are two ways to move a column of data.
1. Click on the column and drag it to a new position. The corresponding Data Layout item shifts to reflect the change.
2. You can also move a column by moving the element in the Data Layout. Click the element in the Data Layout and drag it to a new position.

Sorting the Results Data -

<table>
<thead>
<tr>
<th>Sort Ascending</th>
<th>Sorts the selected column values in ascending order (alphabetical or numeric)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sort Descending</td>
<td>Sorts the selected column values in descending order (alphabetical or numeric)</td>
</tr>
</tbody>
</table>

Use the sort buttons to quickly sort a Results or Table column.

To sort column data in the Results or Table section,
- select the column or item to be sorted
- on the standard toolbar, click the ascending or descending button.

Establish a final sort sequence by reordering sort items
- Items are sorted left to right on the sort item. To reorder the sequence, drag each item to its new position.

You can apply sequenced, nested sort conditions to Request items in the Results or Table section.

To apply sort conditions using the Sort line,
- To display the Sort line, Click Sort on the Section Title bar
- Drag Request items to the Sort line from
  - the Catalog pane
  - Data Layout
  - drag the column
- Establish a final sort sequence by reordering sort items
  - Items are sorted left to right on the sort item. To reorder the sequence, drag each item to its new position.
- Double-click specific sort items to toggle ascending and descending sort orders
- The Sort button changes to Sort Now, Click the Sort Now button
To reverse the sort order for an item, select the item and click the ascending or descending sort icon on the Standard toolbar. Data is sorted in ascending (alphabetical or numerical) order by default.

**Remove Columns**

| Remove | Removes the selected column (or data layout item). |

Removing a column from the Results or Table section will affect all other sections or columns using that data.

- Select the column
  - From the Results dropdown menu click Remove
  - On the shortcut (right mouse click) menu Remove Column.

**Results & Table difference**

**Results** - The only way to bring a column back into the Results section to re-process the Query.

**Table** - When removing a column in from a Table section is does not remove it from the Results section and therefore you can add it back to the Data Layout.

**Applying Totals**

You can apply a Break, Grand and Custom total to any column in a Results or Table section. A Grand total on a numeric column applies a default “sum” function. However, each column can have a number of Grand totals, each with a different aggregate function (such as minimum, maximum, average, etc.) applied to it.

| Grand Total | Opens the Insert Grand Total dialog box. |

**Calculate a single Grand Total column**

Select the column to be totaled and click the Grand Total button on the Standard toolbar. The program displays the total at the bottom of the selected column.

**Calculating multiple Grand Total columns on the same row**

- To apply multiple grand totals on the same row using the sum data function:
  1. Select a column and use either the menu and choose *Table > Grand Total...*
2. The Insert Grand Total dialog box is displayed.

3. From the *Grand total function* drop-down list box, Select the *sum* data function.

4. From the *Add grand total to* list, Select one or more *columns to be totaled* and click *OK*.

**Inserting Break Totals**

The *Break Total* button opens the Insert Break Total dialog box.

Use the Insert Break Total dialog box to apply a break total to a column. Break totals are typically used in reference to subtotals. Subtotals are generated by a break column. The break column contains the data by which you group (break) your total. A break column contains characters (as opposed to numbers). When you apply a break total, the total automatically sorts data by the break column and concatenates the unique values.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>At every break in</td>
<td>The column on which to break.</td>
</tr>
<tr>
<td>Break total function</td>
<td>The data function to apply. Available data functions include:</td>
</tr>
<tr>
<td></td>
<td><em>Sum</em>- Returns the sum of underlying values.</td>
</tr>
<tr>
<td></td>
<td><em>Average</em>- Returns the average of underlying values.</td>
</tr>
<tr>
<td></td>
<td><em>Minimum</em> - Returns the lowest of underlying values.</td>
</tr>
<tr>
<td></td>
<td><em>Maximum</em> - Returns the highest of underlying values.</td>
</tr>
<tr>
<td></td>
<td><em>Count</em> - Returns the number of underlying values.</td>
</tr>
<tr>
<td></td>
<td><em>Other</em> - Allows you to create a <em>Custom Function</em> using <em>JavaScript</em>.</td>
</tr>
<tr>
<td>Add break total to</td>
<td>The column or columns on which to apply the break total.</td>
</tr>
</tbody>
</table>

➢ To apply a break total (subtotal):
1. Select a column and choose **Results** or **Table > Break Total**, or click **Break Total** on the shortcut menu.
   The Insert Break Total dialog box is displayed.

2. Select a **break column** from the **At every break in:** the drop-down list.

3. Select a **data function** from the **Break total function** drop-down list.

4. Select one or more columns from the **Add break total to** list and click **OK**.

5. The following example shows break totals
   - At every break in SI Subcode Desc
   - Break total function: Sum
   - Add break total to: Actual and Encumbrance columns
To remove a break total

- Highlight a break total row by clicking in the left margin.
- On the shortcut menu, click **Remove Row**.
- Or Press the Delete key on your keyboard.

All break totals associated with the rows are removed from the column.

### Hiding/Unhide Column

- **Hide Column**: Hides the selected column from view.
- **Unhide Column**: Opens the Unhide Column dialog box.

To hide a column:
- select the column
- on either the shortcut menu or the Results or Table menu, click **Hide Column**.

To unhide a column:
- click anywhere within the Contents pane
- on either the shortcut menu or the Results menu, click **Unhide Column**...
- when the Unhide Column dialog box is displayed, select the desired column
- click OK
Formatting Results and Tables

<table>
<thead>
<tr>
<th>Format</th>
<th>Results</th>
<th>Tools</th>
<th>UCConn</th>
<th>Format</th>
<th>Table</th>
<th>Tools</th>
<th>UCConn</th>
</tr>
</thead>
<tbody>
<tr>
<td>Font...</td>
<td></td>
<td></td>
<td></td>
<td>Font...</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Style</td>
<td></td>
<td></td>
<td></td>
<td>Style</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Number</td>
<td></td>
<td></td>
<td></td>
<td>Number</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Justify</td>
<td></td>
<td></td>
<td></td>
<td>Justify</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Column</td>
<td></td>
<td></td>
<td></td>
<td>Column</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Row</td>
<td></td>
<td></td>
<td></td>
<td>Row</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

✓ Column Titles
✓ Row Numbers
Text Wrap
Suppress Duplicates

Grid Lines...
Border and Background...
Spotlighter...
Export Properties...

Column Titles

Size Rows
To apply a custom height to a row, drag the bottom edge of the row to the new position.
To apply the standard height to a row, choose Format > Row > Standard Height. When you resize a row, all rows are repositioned in the report.

• Auto-Size Width
• Standard Width

Row Numbers

Hide/Show Row Numbers
To hide row numbers, choose Format > Row Numbers. (The Row Numbers option is unchecked in hidden mode).
To show column titles, choose Format > Column Titles. (The Row Numbers option is checked in show mode.)

• Row numbers can be printed on reports, but cannot be copied to the clipboard or exported to a file.
• Only Rows with Totals can have font formatting applied to them.

Text Wrap

Wrap Text
To wrap text within a column, select the column and click Text Wrap on either the shortcut menu or the Format menu.
Note: This option is available for detail and fact columns.

• Text wrapping can give you narrow or uniform columns to display values without truncation.
Suppress Duplicates

To suppress the duplicate values for a column, select the column and click **Suppress Duplicates** on either the shortcut menu or the Format menu.

- Use this feature if you want to display only the first instance in the column of a duplicate value when individual database records include redundant information.
- This feature is especially useful if records are associated with the same date, location or customer.

The following comparison shows with and without Titles, Row Numbers, Text Wrapping and Suppress Duplicates.

<table>
<thead>
<tr>
<th>Unit</th>
<th>Unit Description</th>
<th>Dept</th>
</tr>
</thead>
<tbody>
<tr>
<td>16</td>
<td></td>
<td>21137</td>
</tr>
<tr>
<td>17</td>
<td></td>
<td>21138</td>
</tr>
<tr>
<td>18</td>
<td>OFC OF VP &amp; COO</td>
<td>30600</td>
</tr>
<tr>
<td>19</td>
<td></td>
<td></td>
</tr>
<tr>
<td>20</td>
<td></td>
<td>30610</td>
</tr>
<tr>
<td>21</td>
<td>05 ATHLETICS</td>
<td>10200</td>
</tr>
<tr>
<td>22</td>
<td></td>
<td></td>
</tr>
<tr>
<td>23</td>
<td></td>
<td></td>
</tr>
<tr>
<td>24</td>
<td></td>
<td></td>
</tr>
<tr>
<td>25</td>
<td></td>
<td>10201</td>
</tr>
</tbody>
</table>

Without or With

Alignment/Justify

To modify the way an item is justified within a row or column, use one of the following options:

- Select an item, choose **Format > Justify**, and select the desired justification.
- Select an item, on the shortcut menu click **Alignment**, and enter the desired changes in the Alignment Properties dialog box.
Gridlines

To modify gridline properties, choose **Format > Grid Lines**, select the grid line feature and enter the desired information in the Gridlines Properties dialog box.

Border & Background

To modify the border of a column, select the column and choose **Format > Borders and Background**.

To modify the background of a Results section, click anywhere within the Contents pane, choose **Format > Borders and Background**, and enter the desired information in the Border and Background Properties dialog box.
Use the Spotlighter to emphasize report elements so that they stand out by applying color and font styles to selected labels. Spotlighter formats are applied conditionally by building an equation and applying the constraint to your report.

**To spotlight exceptional values:**

1. Select an element to spotlight
2. Select **Format > Spotlighter**
3. Build a conditional format in the Spotlighter:
   - Select a comparison operator from the Operator list
   - Enter a comparison value in the Value field
4. Add formatting or colors to spotlight the data by clicking the format toolbar color controls and font controls.
   - The sample text in the dialog box previews your spotlighter formatting.
5. Select **Apply** to apply the spotlight format to the selected report element.
   - The condition is displayed in the format editor with the spotlighter format applied.

Repeat steps 1–5 to specify additional conditions within the same selection.

You can apply multiple conditions to a selection.

For example, you could set values over 5,000 within an item to display red, and those over 10,000 to display bold and green.

**To modify Spotlighter formats**

1. Select a spotlighted report element to modify.
2. Select **Format > Spotlighter.**
3. Double-click the spotlighter format to be modified in the **Format** editor.
   - All conditional formats applied to the selection are captured to the Format editor.
4. Make any desired changes to the condition or format.
5. Select **Apply** to reapply the modified spotlighter format.
   - The modified format is reapplied to the report element.
To copy Spotlighter formats
✓ Select the spotlighted report element to copy.
✓ Select **Format >Spotlighter**.
  The Spotlighter is displayed with the formats applied to the item displayed in the Format editor.
✓ Select **Capture**.
✓ Select the report element to which to apply the spotlighter formats.
  The target area can be in the same report or in a different report.
✓ Select **Restore**.
  The captured formats are applied to the selected report element.

To remove a format from a selected report element
✓ Select a report element.
✓ On the **Format** menu, select **Spotlighter**.
  The Spotlighter formats applied to the report element are displayed in the Format editor.
✓ Select the format to remove in the Format editor.
✓ Click **Delete**.

### Spotlighter Fields

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Operator</strong></td>
<td>Logical operators including:</td>
</tr>
<tr>
<td>=</td>
<td>equal to</td>
</tr>
<tr>
<td>&lt;&gt;</td>
<td>less than, greater than</td>
</tr>
<tr>
<td>&lt;</td>
<td>less than</td>
</tr>
<tr>
<td>&lt;=</td>
<td>less than or equal to</td>
</tr>
<tr>
<td>&gt;</td>
<td>greater than</td>
</tr>
<tr>
<td>&gt;=</td>
<td>greater than or equal to</td>
</tr>
<tr>
<td><strong>Value</strong></td>
<td>Comparison value to define the condition</td>
</tr>
<tr>
<td>✓</td>
<td>Accepts the equation from the Format editor and applies it to the report element.</td>
</tr>
<tr>
<td>✗</td>
<td>Clears the Format editor and resets the style preference to the previous setting.</td>
</tr>
<tr>
<td><strong>Formatting Color and Style</strong></td>
<td>bold text</td>
</tr>
<tr>
<td></td>
<td>italicize text</td>
</tr>
<tr>
<td></td>
<td>underline text</td>
</tr>
<tr>
<td></td>
<td>change fill color</td>
</tr>
<tr>
<td></td>
<td>change text color</td>
</tr>
<tr>
<td><strong>Sample</strong></td>
<td>Preview the formatting to be applied.</td>
</tr>
<tr>
<td><strong>Format Editor</strong></td>
<td>Displays the spotlighter format from a row, column or item.</td>
</tr>
<tr>
<td><strong>Capture</strong></td>
<td>Captures a spotlighter format from a row, column or item.</td>
</tr>
<tr>
<td><strong>Restore</strong></td>
<td>Copies a spotlighter format to a row, column or item.</td>
</tr>
<tr>
<td><strong>Apply</strong></td>
<td>Applies a spotlighter format to a row, column or item.</td>
</tr>
</tbody>
</table>
Export Properties…

**Adding a Header and Footer to the Results or Table**

Adding a Header and Footer to the Results or Table sections can give it a polished look. It is recommended that the columns (data) fit the page orientation (portrait/landscape). You must be in the Print Preview mode to add your Header and Footer.

**Print Preview**
- Placing the Results or Table report in print preview mode, **File > Print Preview**

> Adjust the top, bottom and side margins as needed

> The scrollbar is used to scroll what is on the screen, not through the pages of the report.

> Print Preview Speed Menu **Right mouse Click**
Moving from page to page, **Click** on one of the four “Page” choices - First, Previous, Next or Last

“Start Page Number…” allows you to change the page numbering of your document. This is helpful if you are adding the Result or Table report to another document and want the document numbered consecutively.

Page Header/Footer allows you to add your own Header/Footer information

Use the buttons in the dialog box to add
1. current date
2. time
3. file name
4. page
5. page total
6. limit values

**Click OK.**